Which Sun models run which versions of SunOS?

SunOS 5.x = Solaris 2.x
Sun dropped the "2." when Solaris (2.)7 came out.
i.e. Solaris 7 = "Solaris 2.7" = SunOS 5.7,
Solaris 8 = "Solaris 2.8" = SunOS 5.8 and so on.

Sun2: SunOS 4.0.3 or earlier.
Sun386i: SunOS 4.0, 4.0.1, 4.0.2 only.
Sun3: SunOS 4.1.1 or earlier.
4/100, 4/200 series: SunOS 3.2, SunOS 4.0 through 5.4
4/300 series: SunOS 4.0.3 through 5.4
4/400 series: SunOS 4.1PSR_A through 5.4
600 models 120, 140: SunOS 4.1.2 through 5.5.1
600 model 41, 51: SunOS 4.1.3 through 5.5.1
SPARCstation 1, 1+, SLC, IPC: SunOS 4.0.3 through 5.7
SPARCstation 2, ELC, IPX: SunOS 4.1.1 through 5.7
SPARCstation 4: SunOS 4.1.4 or later.
SPARCstation 5: SunOS 4.1.3_U1B or later.
SPARCstation 10 models 20, 30, 40, 41, 51, 61, 71: SunOS 4.1.3 or later.
SPARCstation 20 models 50, 51, 61, 71: SunOS 4.1.3_U1B or later.
SPARCstation 20 model HS11, HS21, 151: SunOS 4.1.4 or later.
SPARCclassic, SPARCstation LX: SunOS 4.1.3C or later.
SPARCstation Voyager: Solaris 2.3 edition II or later.
Ultra 1 model 140, 170: Solaris 2.5 or later.
Ultra 1 model 140E, 170E, 200E: Solaris 2.5.1 or later.
Ultra 2: Solaris 2.5.1 or later.
Ultra 5,10,30,60,250,450: Solaris 2.5.1HW1297 or Solaris 2.6HW0398 or later.
Ultra Enterprise: Solaris 2.5.1 or later.
SunBlade 100, SunBlade 1000, SunFire 280R: Solaris 8HW1000 or later.
SunFire 3800, 4800, 4810, 6800: Solaris 8HW0401 or later.

The SX framebuffer on the SS10 and 20 is only supported under Solaris 2.x.

SunOS 4.1.3 and later versions of SunOS 4.x have been reported to run on
multiprocessor SuperSPARC configurations of the SS10, SS20, and 600, but
this configuration is not supported by Sun. Anyone who tries this is on
their own. The (unofficial) word from inside Sun about whether or not it
actually works is as follows:

Little testing of the SuperSPARC MP configurations under 4.1.3
have been done by Sun. What little was done showed that under
heavy loads the system was prone to crash (What it really did was
hang, so badly that even an L1-A would not work).
...
We suspect, but do not know, that as the SuperSPARC chips get
faster that the problems will manifest themselves more quickly.

Caveat Emptor.

However, multiprocessor HyperSPARC systems are supported by Ross under both
SunOS 4.1.4 and Solaris 2.x.

SunOS 5.0 runs only on SS1,1+,2,SLC,IPC,ELC,IPX.

While SunOS 5.x does run on the 4/100 and 4/200 systems, the FPU (if
present) is disabled, and floating point is emulated in software. The
latest version of SunOS 5.x (Solaris 2.x) that runs on the 4/100, 4/200,
4/300, and 4/400 systems is 5.4 (Solaris 2.4).

SunOS 5.3 (aka Solaris 2.3) is said to run on the SS5, but without support
for the audio device. Solaris 2.3 Edition II, Solaris 2.3 Hardware 5/94,
and later versions include audio support.

Not all peripherals supported under SunOS 4.x are supported under SunOS
5.x and vice versa. Check with Sun or the peripheral manufacturer.

Explanatory note:

In general, Solaris = SunOS + Open Windows.

Solaris 1.0 = SunOS 4.1.1 + Open Windows 2.0
Solaris 1.0.1 = SunOS 4.1.2 + Open Windows 2.0
Solaris 1.1 = SunOS 4.1.3 + Open Windows 3.0
Solaris 1.1C = SunOS 4.1.3C + Open Windows 3.0 (Classic/LX only)
Solaris 1.1.1 = SunOS 4.1.3_U1 + Open Windows 3.0_U1
Solaris 1.1.1revB = SunOS 4.1.3_U1revB + Open Windows 3.0_U1revB
Solaris 1.1.2 = SunOS 4.1.4 + Open Windows 3.0_414
Solaris 2.0 = SunOS 5.0 + Open Windows 3.0.1
Solaris 2.1 = SunOS 5.1 + Open Windows 3.1
Solaris 2.2 = SunOS 5.2 + Open Windows 3.2
Solaris 2.3 = SunOS 5.3 + Open Windows 3.3
Solaris 2.4 = SunOS 5.4 + Open Windows 3.4
Solaris 2.5 = SunOS 5.5 + Open Windows 3.5
Solaris 2.5.1 = SunOS 5.5.1 + Open Windows 3.5.1
Solaris 2.6 = SunOS 5.6 + Open Windows 3.6
Solaris 7 = SunOS 5.7 + Open Windows 3.6.1
Solaris 8 = SunOS 5.8 + Open Windows 3.6.2



UNIXguide.net
Suggest a Site