Solaris Logical Domain Installation
#./Install/install-ldm
#svcs -l ldmd
#ldm ls
#ldm add-vds primary-vds0 primary
#ldm add-vcc port-range=5000-5100 primary-vcc0 primary
#ldm add-vsw net-dev=e1000g0 primary-vsw0 primary
#ldm list-services primary
VDS
NAME VOLUME OPTIONS DEVICE
primary-vds0
VCC
NAME PORT-RANGE
primary-vcc0 5000-5100
VSW
NAME MAC NET-DEV DEVICE MODE
primary-vsw0 00:14:4f:40:7f:0e e1000g0 switch@0 prog,promisc
#ldm list-bindings
#ldm set-mau 1 primary
#ldm set-vcpu 8 primary
#ldm start-reconf primary (delayed reconfiguration, wait till reboot)
#ldm set-memory 4G primary
#ldm add-config new_config
#ldm list-config
#reboot
(Enable networking between primary and guest domains)
# ifconfig e1000g0 down unplumb
# ifconfig vsw0 plumb
# ifconfig vsw0 192.168.1.2 netmask + broadcast + up
# mv /etc/hostname.e1000g0 /etc/hostname.vsw0
(Enable virtual network terminal server daemon)
# svcadm enable vntsd primary
# svcs vntsd
(Create guest domain)
# ldm add-domain ldom01
# ldm set-mau 1 ldom01
# ldm add-vcpu 8 ldom01
# ldm add-memory 4G ldom01
# ldm add-vnet vnet0 primary-vsw0 ldom01
(Create a volume)
# zfs create -V 5gb rpool/vol01
# ldm add-vdsdev /dev/zvol/dsk/rpool/vol01 vol1@primary-vds0
# ldm add-vdisk vdisk1 vol1@primary-vds0 ldom01
(Set environment variables)
# ldm set-var auto-boot?=true ldom01
# ldm set-var boot-device=vdisk1 ldom01
(Add ISO image)
# ldm add-vdsdev options=ro /data/sol_10.iso iso@primary-vds0
# ldm add-vdisk sol10_iso iso@primary-vds0 ldom01
(Bind and start installing the ldom)
# ldm bind ldom01
# ldm start ldom01
LDom ldom01 started
ok> devalias
ok> boot sol10_iso
(Connect to console)
# ldm list
NAME STATE FLAGS CONS VCPU MEMORY UTIL UPTIME
primary active -n-cv SP 8 4G 0.3% 1h 41m
ldom01 active -n--- 5000 8 2G 48% 0h 32m
#telnet localhost 5000
Recent comments